My heart is broke

Twangled your powervalve grommit in your woodruff key? ask someone how to fix it here
Post Reply
R1andy
Light Smoker
Posts: 46
Joined: Sun Jun 07, 2015 10:05 pm

My heart is broke

Post by R1andy » Mon Feb 20, 2017 11:20 pm

Changed the clutch casing as the cable holder was broken and when it was all bolted back together I noticed I had a coolant leak.

Mechanical water pump seal.

So stripped her down again , new everything , bolted her back together and bam it's f@#king leaking again , aaahhhhhhh

I recon I could have nipped the seal when installing, which may have caused the leak.

Can anyone advise on a full proof way to install a new seal ?
I used a socket and hammer

And the new clutch casing is form a different model than mine, I noticed it has an extra place for a nut at the top section, could This have anything to do with the leak?

Cheers

User avatar
500bernie
Premix Junkie
Posts: 2934
Joined: Mon Aug 02, 2010 10:22 am
Location: Teesside

Re: My heart is broke

Post by 500bernie » Mon Feb 20, 2017 11:27 pm

Hi Andy,
Bad luck :(
Where is the leak coming from?
Post a photo.
It sounds like you have a mixture of KR1 and KR1S bits, I don't think that would give you a leak.
Cheers
Bernie :)
2 Firecracker Red and Grey C3s
Image

R1andy
Light Smoker
Posts: 46
Joined: Sun Jun 07, 2015 10:05 pm

Re: My heart is broke

Post by R1andy » Mon Feb 20, 2017 11:37 pm

Hi Bernie,

It's coming from the small hole beside the coolant plug bolt. The hole is designed to show any leaks, Coolant or oil depending on what seal has gone.

The casing is a perfect fit bar the nut hole , I agree , can't see this causing the leak.

Just need q decent method of installing a new seal

podman
Heavy Smoker
Posts: 276
Joined: Sat Jun 27, 2015 10:51 am

Re: My heart is broke

Post by podman » Tue Feb 21, 2017 9:42 pm

I thought you'd broke the motor.!..I know what you mean thou, you have my sympathy, is the leak bad?

I noticed I had a teeny weep of coolant from this hole since owning my bike Summer 2015 but I havent yet had to top up the expansion bottle or rad,so ive left it, checking levels before n after every ride, (which isnt often to be fair) when(if!) a problem with the engine develops, ill put it right.

User avatar
scooble
Premix Junkie
Posts: 1527
Joined: Thu Jul 27, 2006 12:47 pm
Location: West Sussex
Contact:

Re: My heart is broke

Post by scooble » Wed Feb 22, 2017 8:52 am

I've replaced a couple of these before.
I've always removed the entire side cover. Removed the plastic gears inside. Then used a heat gun to heat up the case and tap it out with an appropriate sized socket.

Do the same in reverse, but also ensure that the hole is smeared with grease before I put the new seal in.
You can use a socket to push it back in, but I had a specially made cylindrical drift that ensures the load is equally distributed around the shoulder of the seal

User avatar
James P
Heavy Smoker
Posts: 454
Joined: Mon Mar 11, 2013 10:47 am
Location: Sydney, Australia

Re: My heart is broke

Post by James P » Thu Feb 23, 2017 1:54 pm

I've tried to get away from using hammers generally, as it has often ended in tears. I installed my last water pump seal using a suitably-sized socket in a bench vice. Using a vice means you can gradually press the seal in and watch/feel for any impending difficulty. Make sure you use a block of wood or other soft material to prevent the vice jaws from damaging any part of the pump/clutch casing.
An alternative but similar method would be to make a special tool using threaded rod (or a long bolt) to draw the seal in.

Regards,
James

R1andy
Light Smoker
Posts: 46
Joined: Sun Jun 07, 2015 10:05 pm

Re: My heart is broke

Post by R1andy » Fri Feb 24, 2017 6:38 pm

Cheers lads for the advice,
Finally got her sorted .

25mm 12 sided socket was the perfect answer. Got her in with zero damage.

I developed a way of changing the water pump seal without stripping half the engine off lol.
Ah, good old experience and the joys of doing it 3 times.
It took 20 minutes at the most and only the water pump gasket to replace.

Thanks again, she is now running well.

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests