Ignition switch or worse?

The place to talk about your Tandem!
Post Reply
Skyeport
Light Smoker
Posts: 36
Joined: Thu Sep 12, 2013 11:07 pm

Ignition switch or worse?

Post by Skyeport » Sun Nov 04, 2018 3:12 am

I suspect my ignition switch is dying.
Does anyone know if they are shared with any other models?
Cheers
Last edited by Skyeport on Thu Nov 08, 2018 10:03 pm, edited 1 time in total.

User avatar
StrokerBoy
Premix Junkie
Posts: 1013
Joined: Thu Jul 27, 2006 9:43 am
Location: Yorkshire
Contact:

Re: Ignition switch

Post by StrokerBoy » Sun Nov 04, 2018 5:50 pm

Not sure, sorry. Try googling the partnumber, which is 27005-5041 I think. I bought a used one from Japan (with key) but they're all a bit worn after all these years.
Kawasaki KR250 Tandem Twin (x4) & KS-II 80,
Yamaha RD350LC,
Suzuki GSX-R750RK & RB50 Gag.

Gerrit
Heavy Smoker
Posts: 266
Joined: Fri Jun 26, 2009 12:09 am
Location: Kingdom of the Netherlands

Re: Ignition switch

Post by Gerrit » Sun Nov 04, 2018 8:04 pm

Wouldn't parts such as ignition switches have been common to many contemporary models, e,g, early GPz900R, GPz600R etc?
"Mine is a long and sad tale", said the mouse.
"Indeed it is", said Alice, looking at the mouse's tail.

podman
Heavy Smoker
Posts: 337
Joined: Sat Jun 27, 2015 10:51 am

Re: Ignition switch

Post by podman » Mon Nov 05, 2018 8:49 pm

Have a browze on Cradleys parts finder ..I did have a quick scan but the GPZ9/600 switch has a different PN to what SB suggests.

I also had a look at ARs and KMXs , not a match.

Maybe an earlier bike ?

http://www.kawasakioriginalparts.com/road-bikes.html

Good luck anyway.

Skyeport
Light Smoker
Posts: 36
Joined: Thu Sep 12, 2013 11:07 pm

Re: Ignition switch

Post by Skyeport » Thu Nov 08, 2018 10:03 pm

Thanks all, don't think it is my switch causing the issue.
Suspect something else, maybe stator, coils or ignition pickups?
Found a broken wire at the back of the switch, fixed it, ran fine for a bit, then died again.
Inspected wiring harness, found multiple dodgy wires ( a few that were just hanging by a thread), luckily I had a very tidy wiring harness on one of my spares bikes. Replaced the entire harness, & checked all connections.
Bike ran great, started fist kick, idled perfectly,off to the servo to get some fuel, then once warmed up and headed out of town for a test ride it starts missing a bit then by the time I get home it is cutting out completely.
Once it had died there were no lights on dash.
Lights come back on if I kick it over? then randomly cuts out again?
Any thoughts on where I should look first? :shock:

User avatar
StrokerBoy
Premix Junkie
Posts: 1013
Joined: Thu Jul 27, 2006 9:43 am
Location: Yorkshire
Contact:

Re: Ignition switch or worse?

Post by StrokerBoy » Fri Nov 09, 2018 12:38 pm

I hate electrics. Sounds like you still have a dodgy connection somewhere. Your 'new' wiring harness will still be 30+ years old, and connections that look good can sometimes fail through vibration. If it's cutting out dead, ignore all the circuits for lights/etc and just focus on the main ones. Have you still got the circuit that stops you putting it in gear with the sidestand down ? Check that, or disable it altogether - it connects to just one CDI box but kills the whole bike. Try tracing the main circuits through, there's a wiring diagram on my site that starts to make sense once you work through it slowly. Might even be a battery issue if you say the lights come back on when you kick it over.
Kawasaki KR250 Tandem Twin (x4) & KS-II 80,
Yamaha RD350LC,
Suzuki GSX-R750RK & RB50 Gag.

podman
Heavy Smoker
Posts: 337
Joined: Sat Jun 27, 2015 10:51 am

Re: Ignition switch or worse?

Post by podman » Fri Nov 09, 2018 9:18 pm

Had a Summer of fun of games with similar symptoms to yours this year on my 350LC, started out very intermittent as in it would cut out maybe once or twice over a 50 mile journey, it went back and forth to an auto electricians(motorcycle specialist) , he changed the fuse box, suspecting the connections but that didnt change anything much.

He then checked out the stator, colis, pick up, CDI etc more than once and all seemed in spec when tested so he renewed all the connections to these , I then started to suspect the carbs and pulled those apart for a clean and check, no change.

then it got worse and on the last ride of the Summer on it, she wouldnt rev over 5,000RPM and would back fire.

Pulled it off the road and sent it to a.nother UK specialist last month who ran it on his dyno until it played up, the load of the dyno highlighted the stator and pick up to be at fault in my case. I swapped all the old components out for a Power Dynamo set up.

I would suggest getting hold of another known running bike and swapping components(did that with a KMX200 many years ago and it was the kill switch at fault in that case) but I guess there isnt many KR250s around to do that so easily with.

Good luck with it and keep us posted.

Skyeport
Light Smoker
Posts: 36
Joined: Thu Sep 12, 2013 11:07 pm

Re: Ignition switch or worse?

Post by Skyeport » Sun Nov 11, 2018 2:50 am

Fingers crossed it seems to have been a dodgy side stand switch.
After checking everything twice and all checked out fine.
I removed the side stand switch to bench test it, seemed fine at first but would intermittently not switch properly.
Disconnected it and bypassed it, test ride was without any missing at all.
Time will tell if that was it!
Thanks for the feedback.

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests